您当前的位置:主页 > 股票公式 >
loadding...

五分钟带你看遍消息事件驱动大智慧指标公式

出处:股票入门网 xingumin.cn时间:2016-11-30 23:08
摘要:五分钟带你看遍消息事件驱动大智慧指标公式。...

五分钟带你看遍消息事件驱动大智慧指标公式


五分钟带你看遍消息事件驱动大智慧指标公式


  B1:=MA(CLOSE,1);

  

  

  B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1) ;

  

  

  SMA2:=MA(B2,5) ;

  

  

  FILLRGN(b2,sma2,b2>sma2),colorred;

  

  

  FILLRGN(b2,sma2,b2<sma2),colorgreen;

  

  

  X:=21;

  

  

  TTY:=H;

  

  

  AAT:=REF(TTY,X)=HHV(TTY,2*X+1);

  

  

  BBT:=FILTER(AAT,X);

  

  

  CCT:=BACKSET(BBT,X+1);

  

  

  HD10T:=FILTER(CCT,X);

  

  

  AA1T:=REF(TTY,X)=LLV(TTY,2*X+1);

  

  

  BB1T:=FILTER(AA1T,X);

  

  

  CC1T:=BACKSET(BB1T,X+1);

  

  

  LD10T:=FILTER(CC1T,X);

  

  

  前期高位:REF(H,BARSLAST(HD10T)),COLORBLUE,LINETHICK0;

  

  

  前期低位:REF(L,BARSLAST(LD10T)),COLORRED,LINETHICK0;

  

  

  T10T:=BARSLAST(HD10T) AND BARSLAST(LD10T) AND NOT(LD10T);

  

  

  STICKLINE(T10T,前期高位,前期高位,20,0),COLORBLUE;

  

  

  STICKLINE(T10T,前期低位,前期低位,20,0),COLORRED;

  

  

  三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);

  

  

  三日量缩:=(MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3));

  

  

  三日价涨A:=C>=REF(C,1);

  

  

  三日价涨B:=C<REF(C,1);

  

  

  三日价涨C:=MIN(MIN(C,REF(C,1)),REF(C,2))>=REF(L,3);

  

  

  TIM:=IF(DATE<1140214,1,0);

  

  

  缩倍柱:=(VOL*1.95<=REF(VOL,1))*TIM;

  

  

  百日低量:=(VOL=LLV(VOL,100))*TIM;

  

  

  倍量柱:=C>REF(C,1)*1.04 AND (VOL>=1.9*REF(VOL,1))*TIM;

  

  

  四日前倍量柱:=(REF(VOL,3)>1.9*REF(VOL,4))*TIM;

  

  

  四日前高量柱:=(REF(VOL,3)>=REF(VOL,4) AND REF(VOL,3)<1.9*REF(VOL,4) AND 三日量缩)*TIM;

  

  

  前三引用不成立:=COUNT(REF(四日前倍量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0 AND COUNT(REF(四日前高量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0;

  

  

  倍量黄金柱:=四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;

  

  

  高量黄金柱:=四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;

  

  

  黄金柱:=倍量黄金柱 OR 高量黄金柱;

  

  

  次倍量黄金柱:=NOT(黄金柱) AND 四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;

  

  

  次高量黄金柱:=NOT(黄金柱) AND 四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;

  

  

  次黄金柱:=次倍量黄金柱 OR 次高量黄金柱;

  

  

  准倍量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前倍量柱 AND ((三日量缩 AND 三日价涨C) OR (COUNT(倍量柱,3)>=1 AND 三日不破)) AND 前三引用不成立;

  

  

  准高量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前高量柱 AND (三日量缩 AND 三日价涨C) AND 前三引用不成立;

  

  

  准黄金柱:=准倍量黄金柱 OR 准高量黄金柱;

  

  

  倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;

  

  

  高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;

  

  

  将军柱:=倍量将军柱 OR 高量将军柱;

  

  

  次倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;

  

  

  次高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;

  

  

  次将军柱:=次倍量将军柱 OR 次高量将军柱;

  

  

  准倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前倍量柱 AND 三日价涨C AND 前三引用不成立;

  

  

  准高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前高量柱 AND 三日价涨C AND 前三引用不成立;

  

  

  准将军柱:=准倍量将军柱 OR 准高量将军柱;

  

  

  BACKSET100:=BACKSET(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱 OR 准将军柱,4);

  

  

  FILTER100:=FILTER(BACKSET100,3);

  

  

  BACKSET101:=BACKSET(黄金柱,4);

  

  

  FILTER101:=FILTER(BACKSET101,3);

  

  

  BACKSET102:=BACKSET(次黄金柱,4);

  

  

  FILTER102:=FILTER(BACKSET102,3);

  

  

  BACKSET103:=BACKSET(准黄金柱,4);

  

  

  FILTER103:=FILTER(BACKSET103,3);

  

  

  BACKSET104:=BACKSET(将军柱,4);

  

  

  FILTER104:=FILTER(BACKSET104,3);

  

  

  BACKSET105:=BACKSET(次将军柱,4);

  

  

  FILTER105:=FILTER(BACKSET105,3);

  

  

  BACKSET106:=BACKSET(准将军柱,4);

  

  

  FILTER106:=FILTER(BACKSET106,3);

  

  

  DRAWTEXT(FILTER101,LOW*0.986,'↖黄金柱'),COLORYELLOW;

  

  

  STICKLINE(FILTER101,OPEN,CLOSE,6,0),COLORYELLOW;

  

  

  DRAWTEXT(FILTER102,LOW*0.986,'↖次黄'){,COLORFF00FF},COLORYELLOW;

  

  

  STICKLINE(FILTER102,OPEN,CLOSE,6,0),COLORYELLOW;

  

  

  DRAWTEXT(FILTER103,LOW*0.986,'↖准黄'),COLORFF00FF{,COLORYELLOW};

  

  

  STICKLINE(FILTER103,OPEN,CLOSE,6,0),COLORYELLOW;

  

  

  DRAWTEXT(FILTER104,LOW*0.986,'↖将军柱'),COLORRED;

  

  

  STICKLINE(FILTER104,OPEN,CLOSE,6,0),COLORYELLOW;

  

  

  DRAWTEXT(FILTER105,LOW*0.986,'↖次将'),COLORFF00FF{,COLORYELLOW};

  

  

  STICKLINE(FILTER105,OPEN,CLOSE,6,0),COLORYELLOW;

  

  

  DRAWTEXT(FILTER106,LOW*0.986,'↖准将'),COLORFF00FF{,COLORYELLOW};

  

  

  STICKLINE(FILTER106,OPEN,CLOSE,6,0),COLORYELLOW;

  

  

  K1:=SUMBARS(FILTER104,1);

  

  

  STICKLINE(K1,REF(L,K1-2),REF(L,K1-2),20,0),COLORYELLOW;

  

  

  STICKLINE(K1,REF(L,K1-1),REF(L,K1-1),3,0),COLORGREEN;{低位线}

  

  

  K2:=SUMBARS(FILTER101,1);

  

  

  STICKLINE(K2,REF(L,K2-2),REF(L,K2-2),20,0),COLORYELLOW;

  

  

  立桩量:=VOL=HHV(VOL,40) AND VOL>1.9*REF(VOL,1);

  

  

  立桩量三日突破:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));

  

  

  立桩量三日不破:=BARSLAST(立桩量)=3 AND REF(LOW,3)<=MIN(MIN(C,REF(C,1)),REF(C,2));

  

  

  BACKSET300:=BACKSET(立桩量三日不破,4);

  

  

  BACKSET301:=BACKSET(立桩量三日突破,4);

  

  

  立桩量成立:=FILTER(BACKSET300,3) AND BACKSET301 AND 立桩量;

  

  

  DRAWTEXT(立桩量成立,HIGH,'←立柱'),COLORGREEN;

  

  

  MA5:=MA(CLOSE,5);

  

  

  MA10:=MA(CLOSE,10);

  

  

  MA30:=MA(CLOSE,30);

  

  

  MA60:=MA(CLOSE,60);

  

  

  MA120:=MA(CLOSE,120);

  

  

  MA240:=MA(CLOSE,240);

  

  

  AA1:=BARSLAST(MA60>MA30 AND (MA30=MA10 OR MA30>MA10));

  

  

  BB1:=REF(COUNT(C<MA60,AA1)=AA1,1);

  

  

  CC1:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;

  

  

  芙蓉出水:=BB1 AND CC1;

  

  

  DRAWTEXT(芙蓉出水,H+0.3,'芙蓉出水'),COLORFF00FF;

  

  

  STICKLINE(芙蓉出水,H,L,5,1),COLORFF00FF;

  

  

  STICKLINE(芙蓉出水,O,C,5,1),LINETHICK2,COLORFF00FF;

  

  

  MA1:=MA(CLOSE,5);

  

  

  MA2:=MA(CLOSE,10);

  

  

  MA3:=MA(CLOSE,20);

  

  

  ZJ:=AMOUNT/10000;

  

  

  TM:=V-MA(V,10);

  

  

  一穿三:=MA1>O AND MA2>O AND MA3>O AND MA1<C AND MA2<C AND MA3<C AND CLOSE>OPEN ;

  

  

  DRAWTEXT(一穿三,L-0.012,'一穿三'),COLORFF00FF;

  

  

  STICKLINE(一穿三,OPEN,CLOSE,5,0),COLORFF00FF;

  

  

  YLZC:=if(close=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(vol+0.01)/100);

  

  

  阻价:=if(close=INDEXC,YLZC+INDEXC-INDEXl,YLZC+(close-low));

  

  

  支价:=if(close=INDEXC,INDEXl+INDEXC-YLZC,low+(close-YLZC));

  

  

  今压:REF(阻价,1),LINETHICK0,COLORGREEN;

  

  

  今撑:REF(支价,1),LINETHICK0;

  

  

  明压:阻价,LINETHICK0;

  

  

  明撑:支价,LINETHICK0;

  

  

  流通亿股: CAPITAL/1000000,COLORBLUE,LINETHICK0;

  

  

  换手:VOL/CAPITAL*100,LINETHICK0,COLORRED;

  

  

  DRAWTEXTREL(1,10,'■所属板块:'+BKNAME),COLORGREEN;

  

  

  DRAWTEXTREL(1,50,'■主营业务:'+SELFSTRING('主营业务')),COLORRED;

  

  

  DRAWTEXTREL(1,90,'■主题库:'+SELFSTRING('主题库')),COLORYELLOW;

  

  

  DRAWTEXTREL(1,120,'■新闻事件驱动:'+SELFSTRING('新闻事件驱动')),COLORYELLOW;



 

相关阅读:

友情链接: