您当前的位置:主页 > 股票公式 >
loadding...

超级好用的通达信主图突破加速

出处:股票入门网 xingumin.cn时间:2016-11-10 20:08
摘要:超级好用的通达信主图突破加速。...

 超级好用的通达信主图突破加速


好用的通达信主图突破加速


   N1:=30;


    N2:=199;


    牛线:MA(COST(98),2)COLOR4080FF,LINETHICK2;


    强压力:HHV((MA(C,1)),N2)*0.93 COLORGREEN,LINETHICK1;


    H1:EMA(CLOSE,6),COLORWHITE DOTLINE;


    IF((ATAN((H1/REF(H1,1)-1)*100)*57.3)>N1,H1,DRAWNULL),COLORWHITE,LINETHICK2;


    STICKLINE(CROSS(C,H1)AND C/REF(C,1)>=1.09,O,C,0.9,0),COLORMAGENTA;


    H2:EMA(EMA(CLOSE,6),18),COLORMAGENTA DOTLINE;


    IF(H1>H2 AND (ATAN((H2/REF(H2,1)-1)*100)*57.3)>5,H2,DRAWNULL),COLORMAGENTA,LINETHICK2;


    DRAWICON(CROSS(H1,H2*1.008) ,H2,1);


    MA50:MA(C,50),COLOR81A5C6,LINETHICK1;


    IF((ATAN((MA(C,50)/REF(MA(C,50),1)-1)*100)*57.3)>=15,MA(C,50),DRAWNULL),COLOR81A5C6,LINETHICK2;


    DRAWICON(CROSS(EMA(EMA(CLOSE,6),18),MA50) ,MA50*0.96,9);


    DRAWTEXT(REF(强压力,1)<=REF(强压力,2)*1.012


    AND (ATAN((EMA(CLOSE,6)/REF(EMA(CLOSE,6),1)-1)*100)*57.3)>N1 AND C>=强压力


    AND 强压力>REF(强压力,1),L*0.97,'突破')COLORRED;


    {洗盘杀入线}


    {T1:=CONST(LLVBARS(LOW,N2));


    T1HIGH:=CONST(REF(HIGH,T1));


    EE:=CONST(CURRBARSCOUNT);


    T2:=CONST(BARSLAST((CURRBARSCOUNT >(EE+T1)) AND (HIGH>T1HIGH)));


    T2HIGH:=CONST(REF(HIGH,T2));


    T3:=CONST(BARSLAST((CURRBARSCOUNT >(EE+T2)) AND (HIGH>T2HIGH)));


    T3HIGH:=CONST(REF(HIGH,T3));


    洗盘杀入线:DRAWLINE(CURRBARSCOUNT=T3+1, T3HIGH, ISLASTBAR, T3HIGH, 1),LINETHICK2,COLOR0000FF;


    DRAWTEXT(ISLASTBAR, T3HIGH,'洗盘杀入线'),LINETHICK1,COLORYELLOW;}


    {止损线}


    {STICKLINE(ISLASTBAR,HHV(C,5)*0.95-0.01,HHV(C,5)*0.95,50,0),COLOR00FFFF;


    DRAWTEXT(ISLASTBAR,HHV(C,5)*0.96,'止损价位'),COLORYELLOW;}


    {徐九}


    A001:=C>REF(C,4);


    NT:=BARSLASTCOUNT(A001);


    TJ11:=NT=9;


    TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);


    AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;


    DRAWTEXT(AY>0,H*1.02,VAR2STR(AY,0)),COLORFF00FF;


    DRAWTEXT(NT=9,H*1.02,'9'),COLORGREEN;


    B01:=C<REF(C,4);


    NT0:=BARSLASTCOUNT(B01);


    TJ21:=NT0=9 ;


    TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);


    AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;


    DRAWTEXT(AY1>0,L*0.98,VAR2STR(AY1,0)),COLORFF00FF;


    DRAWTEXT(NT0=9,L*0.98,'9'),COLORGREEN;


    TT:=240/FROMOPEN;


    比:=TT;


    YYA4:=MA(CLOSE,20);


    YYA5:=(CLOSE > MA(CLOSE,5));


    YYA6:=(MA(CLOSE,5) > MA(CLOSE,10));


    YYA7:=(CLOSE > MA(CLOSE,10));


    YYA8:=(MA(CLOSE,5) > MA(CLOSE,20));


    YYA9:=(CLOSE > MA(CLOSE,20));


    YYA10:=REF(YYA4,1);


    YYA11:=(YYA4 > YYA10);


    YYAVX:=(((((IF(YYA5,10,(0 - 10)) + IF(YYA6,10,(0 - 10))) + IF(YYA7,10,(0 - 10))) + IF(YYA8,10,(0 - 10))) + IF(YYA9,10,(0 - 10))) + IF(YYA11,10,(0 - 10)));


    DSLX:=(CLOSE / INDEXC);


    DSLX1:=MA(DSLX,5);


    DSLX2:=MA(DSLX,10);


    YYV1:=MA(VOL,5);


    YYV2:=MA(VOL,10);


    情况1:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0)),NODRAW;


    情况2:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));


    情况3:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 > YYV2)) AND (DSLX < DSLX1)),1,0));


    情况4:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 <= YYV2)) AND (DSLX < DSLX1)),1,0));


    情况5:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));


    情况6:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));


    情况7:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));


    情况8:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));


    情况9:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));


    情况10:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));


    情况11:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0)),NODRAW;


    情况12:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));


    情况13:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));


    情况14:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));


    情况15:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));


    情况16:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));


    大盘1:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 >= YYV2)),1,0));


    大盘2:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 < YYV2)),1,0));


    大盘3:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 >= YYV2)),1,0));


    大盘4:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 < YYV2)),1,0));


    大盘5:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)),1,0));


    大盘6:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)),1,0));


    大盘7:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)),1,0));


    大盘8:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)),1,0));


    MFI:=(HIGH-LOW)*1000000/(VOL*比);


    绿灯:=MFI>=REF(MFI,1)AND VOL*比>=REF(VOL,1);


    MMM1:=CONST(绿灯);


    衰退:=MFI<REF(MFI,1)AND VOL*比<REF(VOL,1);


    MMM2:=CONST(衰退);


    伪装:=MFI>=REF(MFI,1)AND VOL*比<REF(VOL,1);


    MMM3:=CONST(伪装);


    蛰伏:=MFI<REF(MFI,1)AND VOL*比>=REF(VOL,1);


    MMM4:=CONST(蛰伏);


    WJ:=(H+L+C)/3;


    V1:=IF(H=L,1,H-MAX(O,C));


    V2:=IF(H=L,1,MAX(C,O)-WJ);


    V3:=IF(H=L,1,MIN(O,C)-L);


    V4:=IF(H=L,1,WJ-MIN(C,O));


    V5:=VOL/IF(H=L,4,H-L);


    V6:=(V1*V5);


    V7:=(V2*V5);


    V8:=(V3*V5);


    V9:=(V4*V5);


    买盘1:=DYNAINFO(23)*比;


    卖盘1:=DYNAINFO(22)*比;


    买盘2:=IF(ISLASTBAR AND C>300,(V9+V8)*TT,(V9+V8));


    卖盘2:=IF(ISLASTBAR AND C>300,(V6+V7)*TT,(V6+V7));


    买盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,买盘1,买盘2);


    卖盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,卖盘1,卖盘2);


    {买卖差:=买盘-卖盘;}


    量大:=(卖盘+买盘)/REF(VOL,1)>2;


    MMM5:=CONST(量大);


    量缩:=REF(VOL,1)/(卖盘+买盘)>1.5;


    MMM6:=CONST(量缩);


    卖量大:=(卖盘-买盘)/买盘>0.4;


    MMM7:=CONST(卖量大);


    买量大:=(买盘-卖盘)/卖盘>0.4;


    MMM8:=CONST(买量大);


    DRAWTEXT_FIX(情况1=1 ,0.10,0,0,'量能理想,明显走强,中线参与,仓位控制在70%左右。'),COLORFF00FF;


    DRAWTEXT_FIX(情况2=1 ,0.10,0,0,'走势趋强,量能不足,短线进场,仓位控制在50%左右。'),COLORFF00FF;


    DRAWTEXT_FIX(情况3=1 ,0.10,0,0,'量价良好,并无明显走强,短线可进场,仓位50%左右。'),COLORFF00FF;


    DRAWTEXT_FIX(情况4=1 ,0.10,0,0,'形态尚可,量能不足,未全走强,短入,仓位30%左右。'),COLORFF00FF;


    DRAWTEXT_FIX(情况5=1 ,0.10,0,0,'形态已变坏,走势尚可,重仓者减大半,清仓者%观望。'),COLOR00FFFF;


    DRAWTEXT_FIX(情况6=1 ,0.10,0,0,'随大盘下跌,明显缩量,考虑大盘风险,减持或清仓。'),COLOR00FFFF;


    DRAWTEXT_FIX(情况7=1 ,0.10,0,0,'该股放量下跌,走势明显偏弱,不抢反弹,离场观望。'),COLORFFFFFF;


    DRAWTEXT_FIX(情况8=1 ,0.10,0,0,'该股缩量下跌,走势偏弱无力,人气散失,离场观望。'),COLORFFFF00;


    DRAWTEXT_FIX(情况9=1 ,0.10,0,0,'该股形态良好,强势明显,量能充足,可以继续持有。'),COLOR00FFFF;


    DRAWTEXT_FIX(情况10=1,0.10,0,0,'上行趋势不变,强势依然,量能开始转弱,注意风险。'),COLOR00FFFF;


    DRAWTEXT_FIX(情况11=1,0.10,0,0,'该股仍然具备上涨潜力,但股性偏弱,可以考虑减仓。'),COLORFFFFFF;


    DRAWTEXT_FIX(情况12=1,0.10,0,0,'该股走势趋弱,量能明显不足,减大部分筹码或空仓。'),COLORFFFF00;


    DRAWTEXT_FIX(情况13=1,0.10,0,0,'该股形态不佳,注意成交量变化,但目前不适合参与。'),COLORFFFF00;


    DRAWTEXT_FIX(情况14=1,0.10,0,0,'该股趋势不明,股价偏弱,注意量能变化,暂不参与。'),COLORFFFF00;


    DRAWTEXT_FIX(情况15=1,0.10,0,0,'有走强迹象,但量能不足,趋势不明朗,不适合操作。'),COLORFFFF00;


    DRAWTEXT_FIX(情况16=1,0.10,0,0,'该股走势太弱,主动性买盘弱,没有太大的参与价值。'),COLORFFFFFF;


    DRAWTEXT_FIX(大盘1,0.10,0.05,0,'总势量能理想,70%仓位, 若最佳买点,否则谨慎介入。'),COLOR00FF00;


    DRAWTEXT_FIX(大盘2,0.10,0.05,0,'总势趋强,量不足,若前轮下跌,短进50%,量大加仓。'),COLORFF00FF;


    DRAWTEXT_FIX(大盘3,0.10,0.05,0,'总势形态走坏,重仓者可减去大部分仓位或放空筹码。'),COLORAAAAAA;


    DRAWTEXT_FIX(大盘4,0.10,0.05,0,'总势缩量调整,注意大盘系统风险,短线可清仓观望。'),COLORFFFFFF;


    DRAWTEXT_FIX(大盘5,0.10,0.05,0,'总势走势良好,量能理想,可继续持有或加仓强势股。'),COLOR00FFFF;


    DRAWTEXT_FIX(大盘6,0.10,0.05,0,'总势形态良好,但量能稍显不足,随时准备减仓调仓。'),COLOR00FF00;


    DRAWTEXT_FIX(大盘7,0.10,0.05,0,'总势趋势不明,注意成交量变化,目前暂不适宜进场。'),COLORFFFFFF;


    DRAWTEXT_FIX(大盘8,0.10,0.05,0,'总势趋势向下,量能萎缩,短线可杀跌,不适合进场。'),COLORFFFFFF;


    DRAWTEXT_FIX(MMM1,0.10,0.10,0,'[绿灯]实计交易量增加。MFI促进指数增加。'),COLORFFFFFF;


    DRAWTEXT_FIX(MMM2,0.10,0.10,0,'[衰退]实计交易量减少。MFI促进指数减少。'),COLORGREEN;


    DRAWTEXT_FIX(MMM3,0.10,0.10,0,'[伪装]实计交易量减少。MFI促进指数增加。'),COLORGREEN;


    DRAWTEXT_FIX(MMM4,0.10,0.10,0,'[蛰伏]实计交易量增加。MFI促进指数减少。'),COLORYELLOW;


    DRAWTEXT_FIX(MMM5,0.10,0.15,0,'★今天比昨天的成交量放大一倍以上。'),COLORGREEN;


    DRAWTEXT_FIX(MMM6,0.10,0.15,0,'★今天比昨天的成交量缩量一半以上。'),COLORYELLOW;


    DRAWTEXT_FIX(MMM7,0.10,0.20,0,'☆该股今天卖出量大于买入量40%以上。'),COLORGREEN;


    DRAWTEXT_FIX(MMM8,0.10,0.20,0,'☆该股今天买入量大于卖出量40%以上。'),COLORYELLOW;


    Z11:=STRCAT(DYBLOCK,' ');


    Z22:=STRCAT(Z11,HYBLOCK);


    Z3:=STRCAT(Z22,' ');


    Z4:=STRCAT(Z3,GNBLOCK);


    Z5:=STRCAT(Z4,' ');


    Z6:=STRCAT(Z5,FGBLOCK);


    DRAWTEXT_FIX(ISLASTBAR,0.4,0.012,0,STRCAT(Z6,ZHBLOCK)),COLORRED;


    DRAWTEXT_FIX(1,0,0.075,0,STRCAT('',ZDBLOCK)),COLORYELLOW;


 

相关阅读:

友情链接: